How to fix Confixx after perl/CPAN update?

Daniel Urstöger
27-01-2010 13:29

If you encounter errors like this one:

Can't locate loadable object for module Confixx::Filter 
in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.0 
/usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 
/usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at
 /root/confixx/confixx_counterscript.pl line 2Compilation failed in require at
 /root/confixx/confixx_counterscript.pl line 2.BEGIN failed--compilation aborted at 
/root/confixx/confixx_counterscript.pl line 2.

It is usually quite trivial to fix, since the only thing missing is a CPAN module required by Confixx:
You need to find you confixx installation folder, e.g.: /root/confixx, then do the following:

  • cd /root/confixx/admin/CPAN
  • tar -zxf Updater-1.0.6.tar.gz
    (the -1.0.6 might be different, e.g.: 1.0.5, what ever version you have installed of Confixx)
  • cd Updater-1.0.6
  • perl Makefile.PL
  • make install

That should be it.

Average rating: 0 (0 Votes)

You cannot comment on this entry