How do I install Adobe Flash Media Server 3.0 on Debian Etch?

Daniel Urstöger
02-07-2009 21:05

Hello folks,

I stumbled into this myself and so I wanted to tell you how I did fix that problem. One thing for starters: I did install it on the 32 bit version of Debian Etch, so if you try it on 64bit Debian Etch you might run into other issues.

  • aptitude install iceweasel ibstdc++5 libnspr4-0d
  • now we run the installer:
    ./installFMS -platformWarnOnly
    (I kept everything asked at its default settings)
  • ln -s /usr/lib/libnspr4.so.0d /usr/lib/libnspr4.so
    ln -s /usr/lib/iceweasel/libplc4.so /usr/lib/libplc4.so
    ln -s /usr/lib/iceweasel/libplds4.so /usr/lib/libplds4.so
    ln -s /opt/adobe/fmslibasneu.so.1 /usr/lib/libasneu.so.1

Well that is about it. With ./fmscore you should be able to fire the baby up. If something is not working try:

  • ldd fmscore

Output shout look like this:

linux-gate.so.1 => (0xffffe000)
libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7f0c000)
libnspr4.so => /usr/lib/libnspr4.so (0xb7edb000)
libplc4.so => /usr/lib/libplc4.so (0xb7ed5000)
libplds4.so => /usr/lib/libplds4.so (0xb7ed2000)
libasneu.so.1 => /usr/lib/libasneu.so.1 (0xb7ec9000)
librt.so.1 => /lib/tls/i686/cmov/librt.so.1 (0xb7ec0000)
libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7ebc000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7dd7000)
libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7db1000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7da6000)
libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7c75000)
/lib/ld-linux.so.2 (0xb7f2b000)

If a library is missing, you could try to use "aptitude search LIBNAME" to get it.

I have not yet made a decent start up script, once I did that I will post it here too.

Average rating: 0 (0 Votes)

You cannot comment on this entry